CVE-2026-40046: Apache ActiveMQ · Integer Overflow or Wraparound
Affects Apache ActiveMQSource CVE Database V5
Mentioned vulnerabilities
Not known to be exploited · CVSS 7.5 High : upgrade to 6.2.4 soon.
Data as of 30 Oct 2026, 06:59 UTC
- EPSS
- 0.3% chance of exploitation in 30 days – higher than 31% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 6.2.4
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:HExploitation evidence
Disclosed: evidence found.
CVE published 9 Apr 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade Apache ActiveMQ and Apache ActiveMQ All and Apache ActiveMQ MQTT and org.apache.activemq/activemq and Apache Software Foundation/org.apache.activemq:apache-activemq and Apache Software Foundation/org.apache.activemq:activemq-all and Apache Software Foundation/org.apache.activemq:activemq-mqtt to 6.2.4.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Apache Software FoundationApache ActiveMQ | Affected
| Fixed in
|
| Apache Software FoundationApache ActiveMQ All | Affected
| Fixed in
|
| Apache Software FoundationApache ActiveMQ MQTT | Affected
| Fixed in
|
Mavenorg.apache.activemq/activemqpkg:maven/org.apache.activemq/activemqOther threats | Affected
| Fixed in
|
MavenApache Software Foundation/org.apache.activemq:apache-activemqpkg:maven/Apache Software Foundation/org.apache.activemq:apache-activemqOther threats | Affected
| Fixed in
|
MavenApache Software Foundation/org.apache.activemq:activemq-allpkg:maven/Apache Software Foundation/org.apache.activemq:activemq-allOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Users should upgrade affected Apache ActiveMQ installations to version 6.2.4 or to a 5.19.x version starting with 5.19.2 or later, as these versions include the fix for this vulnerability. Patch status is confirmed by the vendor advisory recommending these versions. No other mitigation or temporary workaround is indicated.
Description
Integer Overflow or Wraparound vulnerability in Apache ActiveMQ, Apache ActiveMQ All, Apache ActiveMQ MQTT. The fix for "CVE-2025-66168: MQTT control packet remaining length field is not properly validated" was only applied to 5.19.2 (and future 5.19.x) releases but was missed for all 6.0.0+ versions. This issue affects Apache ActiveMQ: from 6.0.0 before 6.2.4; Apache ActiveMQ All: from 6.0.0 before 6.2.4; Apache ActiveMQ MQTT: from 6.0.0 before 6.2.4. Users are recommended to upgrade to version 6.2.4 or a 5.19.x version starting with 5.19.2 or later (currently latest is 5.19.5), which fixes the issue.