CVE-2026-40091: authzed spicedb · Sensitive Data in Logs
Affects authzed spicedbSource CVE Database V5
Not known to be exploited · CVSS 6.0 Medium : upgrade to 1.51.1 when convenient.
Data as of 30 Oct 2026, 11:52 UTC
- EPSS
- 0.1% chance of exploitation in 30 days – higher than 5% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 1.51.1
CVSS:3.1/AV:L/AC:L/PR:H/UI:N/S:C/C:H/I:N/A:NExploitation evidence
Disclosed: evidence found.
CVE published 14 Apr 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade authzed spicedb to 1.51.1.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| authzedspicedb | Affected
| Fixed in
|
GitHubauthzed/spicedbpkg:github/authzed/spicedbOther threats | Affected
| Fixed in– |
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade SpiceDB to version 1.51.1 or later where this issue is fixed. If immediate upgrade is not possible, change the log level from info to warn or error to prevent logging sensitive datastore credentials during startup.
Description
CVE-2026-40091 is a vulnerability in authzed's SpiceDB versions 1.49.0 through 1.51.0 where the startup configuration log at info level includes the full datastore DSN with the plaintext password. This sensitive information exposure occurs in the DatastoreConfig. URI field. The issue is fixed in version 1.51.1.