Skip to main content
VulnerabilityPublished

CVE-2026-40172: goauthentik authentik · Improper Privilege Management

Affects goauthentik authentikSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 8.1 High : upgrade to 2026.2.3 or 2025.12.5 soon.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 3.1 base score
8.1High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.5% chance of exploitation in 30 days – higher than 45% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2026.2.3, 2025.12.5
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 22 May 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade authentik to 2026.2.3 or 2025.12.5; github.com/goauthentik/authentik to 2025.12.5.

Affected software

ProductAffectedFixed in
goauthentikauthentikAffected
  • >=2026.2.0-rc1 <2026.2.3
Fixed in
  • 2026.2.3
goauthentikauthentikAffected
  • <2025.12.5
Fixed in
  • 2025.12.5
Gogithub.com/goauthentik/authentikpkg:golang/github.com/goauthentik/authentikOther threatsAffected
  • <2025.12.5
Fixed in
  • 2025.12.5

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade authentik to version 2025.12.5 or later, or to version 2026.2.3 or later. These versions contain the fix that enforces the enable_group_superuser requirement and prevents unauthorized assignment of superuser groups via the PATCH user API. Patch status is confirmed fixed in these versions. No other mitigations are indicated.

Description

A privilege escalation vulnerability exists in authentik versions prior to 2025.12.5 and between 2026.2.0-rc1 and 2026.2.2. The PATCH /api/v3/core/users/{pk}/ API allows users with change_user permission on a target user to assign arbitrary groups, including those with superuser privileges, without requiring the enable_group_superuser flag. This bypasses stricter permission controls in group management and enables escalation to administrator-equivalent privileges. The issue is fixed in versions 2025.

References

Community reviews

Loading reviews…