CVE-2026-40212: OpenStack Skyline · XSS or 'Cross-site Scripting'
Affects OpenStack SkylineSource CVE Database V5
Not known to be exploited · CVSS 5.4 Medium : upgrade to 5.0.1 when convenient.
Data as of 30 Oct 2026, 11:52 UTC
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 12% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 5.0.1
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:NExploitation evidence
Disclosed: evidence found.
CVE published 10 Apr 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade OpenStack Skyline to 5.0.1.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| OpenStackSkyline | Affected
| Fixed in
|
AI-suggested
If you cannot patch yet, administrators should exercise caution when accessing instance console logs and consider limiting access to trusted users only. Monitoring vendor channels for updates is recommended.
Description
OpenStack Skyline before 5.0.1, 6.0.0, and 7.0.0 has a DOM-based Cross-Site Scripting (XSS) vulnerability in the console because document.write is used unsafely, which is relevant in scenarios where administrators use the console web interface to view instance console logs.