Skip to main content
VulnerabilityPublished Updated

CVE-2026-40244: AcademySoftwareFoundation openexr · Integer Overflow or Wraparound

Affects AcademySoftwareFoundation openexrSource CVE Database V5

0
Compare

Mentioned vulnerabilities

Not known to be exploited · CVSS 8.4 High · fixed in 3.4.10 : patch AcademySoftwareFoundation openexr soon.

Data as of 30 Oct 2026, 06:59 UTC

CVSS 4.0 base score
8.4High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.4% chance of exploitation in 30 days – higher than 36% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 3.4.10, 3.3.10, 3.2.8
CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:A/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 21 Apr 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade AcademySoftwareFoundation openexr to 3.4.10, 3.3.10 or 3.2.8.

Affected software

ProductAffectedFixed in
AcademySoftwareFoundationopenexrAffected
  • >=3.4.0 <3.4.10
Fixed in
  • 3.4.10
AcademySoftwareFoundationopenexrAffected
  • >=3.3.0 <3.3.10
Fixed in
  • 3.3.10
AcademySoftwareFoundationopenexrAffected
  • >=3.2.0 <3.2.8
Fixed in
  • 3.2.8
GitHubacademysoftwarefoundation/openexrpkg:github/academysoftwarefoundation/openexrOther threatsAffected
  • 3.2.0 – 3.4.10
6 affected builds
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Fixed versions 3.2.8, 3.3.10, and 3.4.10 address this vulnerability by correcting the integer arithmetic to prevent overflow. Users should upgrade to these or later versions to remediate the issue. The Red Hat advisory does not indicate any temporary mitigations or that no action is required. Patch status is confirmed by the version fixes stated in the description. No cloud service remediation applies as this is a library. Check the vendor advisory for the latest updates.

Description

OpenEXR provides the specification and reference implementation of the EXR file format, an image storage format for the motion picture industry. In versions 3.4.0 through 3.4.9, 3.3.0 through 3.3.9, and 3.2.0 through 3.2.7, `internal_dwa_compressor.h:1722` performs `curc->width * curc->height` in `int32` arithmetic without a `(size_t)` cast. This is the same overflow pattern fixed in other locations by the recent CVE-2026-34589 batch, but this line was missed. Versions 3.4.10, 3.3.10, and 3.2.8 contain a fix that addresses `internal_dwa_compressor.h:1722`.

References

Community reviews

Loading reviews…