Skip to main content
VulnerabilityPublished Updated

CVE-2026-40252: labring FastGPT · Improper Access Control

Affects labring FastGPTSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 5.3 Medium : upgrade to 4.14.10.4 when convenient.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 4.0 base score
5.3Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 27% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 4.14.10.4
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:N/VA:L/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 10 Apr 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade FastGPT and labring/FastGPT to 4.14.10.4.

Affected software

ProductAffectedFixed in
labringFastGPTAffected
  • <4.14.10.4
Fixed in
  • 4.14.10.4
GitHublabring/FastGPTpkg:github/labring/FastGPTOther threatsAffected
  • <4.14.10.4
Fixed in
  • 4.14.10.4

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

This vulnerability is fixed in FastGPT version 4.14.10.4. Users should upgrade to version 4.14.10.4 or later to remediate this issue. Since the product is not a cloud service, remediation requires applying the official patch by updating the software. Patch status is confirmed by the vendor advisory stating the fix is included in version 4.14.10.4.

Description

FastGPT is an AI Agent building platform. Prior to 4.14.10.4, Broken Access Control vulnerability (IDOR/BOLA) allows any authenticated team to access and execute applications belonging to other teams by supplying a foreign appId. While the API correctly validates the team token, it does not verify that the requested application belongs to the authenticated team. This leads to cross-tenant data exposure and unauthorized execution of private AI workflows. This vulnerability is fixed in 4.14.10.4.

References

Community reviews

Loading reviews…