CVE-2026-40308: my-calendar (WordPress plugin) · Insecure Direct Object Reference
Affects my-calendar (WordPress plugin)Source CVE Database V5
Not known to be exploited · public detection template (Nuclei) · CVSS 8.8 High : upgrade to 3.7.7 soon.
Data as of 30 Oct 2026, 11:52 UTC
- EPSS
- 0.9% chance of exploitation in 30 days – higher than 60% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 3.7.7
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:H/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 16 Apr 2026
Detectable: evidence found.
nuclei template: My Calendar WordPress Plugin - Information Disclosure
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade my-calendar and joedolson/my-calendar to 3.7.7.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| joedolsonmy-calendar | Affected
| Fixed in
|
GitHubjoedolson/my-calendarpkg:github/joedolson/my-calendarOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade the My Calendar plugin to version 3.7.7 or later, where this vulnerability has been fixed. No other mitigations are specified. Patch status is confirmed by the vendor's versioning information. Until upgraded, consider restricting access to the vulnerable AJAX endpoint if possible.
Description
A vulnerability in the My Calendar WordPress plugin (versions 3.7.6 and below) allows unauthenticated attackers to exploit an AJAX endpoint that improperly parses user-supplied parameters. On WordPress Multisite installations, this enables unauthorized access to calendar events from any sub-site by switching to arbitrary site IDs. On single-site installations, the flaw causes a PHP fatal error leading to denial of service. The issue is fixed in version 3.7.7.