Skip to main content
VulnerabilityPublished

CVE-2026-40322: siyuan · Cross-site Scripting

Affects siyuanSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 9.1 Critical : upgrade to 3.6.4 as a priority.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 3.1 base score
9.1Critical
How severe the flaw is on the 0–10 CVSS scale.

Contested

Critical score, yet low EPSS after six months
EPSS
0.3% chance of exploitation in 30 days – higher than 23% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 3.6.4
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 16 Apr 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade siyuan and siyuan-note/siyuan to 3.6.4.

Affected software

ProductAffectedFixed in
siyuan-notesiyuanAffected
  • <3.6.4
Fixed in
  • 3.6.4
GitHubsiyuan-note/siyuanpkg:github/siyuan-note/siyuanOther threatsAffected
  • <3.6.4
Fixed in
  • 3.6.4

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade SiYuan to version 3.6.4 or later, where this vulnerability is fixed. Since the vendor advisory confirms the issue is resolved in 3.6.4, applying this official fix is the recommended remediation. No additional mitigations are specified.

Description

SiYuan versions 3.6.3 and below have a critical stored cross-site scripting (XSS) vulnerability due to insecure rendering of Mermaid diagrams with securityLevel set to "loose". This allows attacker-controlled javascript: URLs to be injected into the DOM. On desktop Electron builds with nodeIntegration enabled and contextIsolation disabled, this XSS can escalate to arbitrary code execution when a user interacts with a malicious Mermaid diagram. The issue is fixed in version 3.6.4.

References

Community reviews

Loading reviews…