Skip to main content
VulnerabilityPublished Updated

CVE-2026-40351: labring FastGPT · Improper Neutralization of Special Elements in Data Query Logic

Affects labring FastGPTSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 9.8 Critical : upgrade to 4.14.9.5 as a priority.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 3.1 base score
9.8Critical
How severe the flaw is on the 0–10 CVSS scale.

Contested

Critical score, yet low EPSS after six months
EPSS
0.6% chance of exploitation in 30 days – higher than 49% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 4.14.9.5
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 17 Apr 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade FastGPT and labring/FastGPT to 4.14.9.5.

Affected software

ProductAffectedFixed in
labringFastGPTAffected
  • <4.14.9.5
Fixed in
  • 4.14.9.5
GitHublabring/FastGPTpkg:github/labring/FastGPTOther threatsAffected
  • <4.14.9.5
Fixed in
  • 4.14.9.5

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade FastGPT to version 4.14.9.5 or later, where this vulnerability has been fixed. Since the vendor advisory confirms the fix in this version, applying this official update fully mitigates the issue. No additional mitigations are specified or required.

Description

FastGPT is an AI Agent building platform. In versions prior to 4.14.9.5, the password-based login endpoint uses TypeScript type assertion without runtime validation, allowing an unauthenticated attacker to pass a MongoDB query operator object (e.g., {"$ne": ""}) as the password field. This NoSQL injection bypasses the password check, enabling login as any user including the root administrator. This issue has been fixed in version 4.14.9.5.

References

Community reviews

Loading reviews…