Skip to main content
VulnerabilityPublished Updated

CVE-2026-40453: Apache Camel JMS · Improper Handling of Case Sensitivity

Affects Apache Camel JMSSource CVE Database V5

0
Compare

Mentioned vulnerabilities

Not known to be exploited · CVSS 9.9 Critical · fixed in 4.20.0 : patch Apache Camel JMS as a priority.

Data as of 29 Oct 2026, 19:04 UTC

CVSS 3.1 base score
9.9Critical
How severe the flaw is on the 0–10 CVSS scale.
EPSS
2.1% chance of exploitation in 30 days – higher than 81% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 4.20.0, 4.18.2, 4.14.6 +1
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 27 Apr 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: evidence found.

    Public exploit code: GitHub proofs of concept

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), GitHub proofs of concept, the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade Apache Camel JMS and Apache Camel CoAP and Apache Camel Google PubSub and Apache Software Foundation/org.apache.camel:camel-jms and Apache Software Foundation/org.apache.camel:camel-coap and Apache Software Foundation/org.apache.camel:camel-google-pubsub to 4.20.0, 4.18.2 or 4.14.6; org.apache.camel/camel-jms to 4.18 or 4.14.6.

Affected software

ProductAffectedFixed in
Apache Software FoundationApache Camel JMSAffected
  • >=4.19.0 <4.20.0
Fixed in
  • 4.20.0
Apache Software FoundationApache Camel JMSAffected
  • >=4.15.0 <4.18.2
Fixed in
  • 4.18.2
Apache Software FoundationApache Camel JMSAffected
  • >=3.0.0 <4.14.6
Fixed in
  • 4.14.6
Apache Software FoundationApache Camel CoAPAffected
  • >=4.19.0 <4.20.0
Fixed in
  • 4.20.0
Apache Software FoundationApache Camel CoAPAffected
  • >=4.15.0 <4.18.2
Fixed in
  • 4.18.2
Apache Software FoundationApache Camel CoAPAffected
  • >=3.0.0 <4.14.6
Fixed in
  • 4.14.6

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available. Users should upgrade to Apache Camel version 4.20.0 or later. For users on the 4.14.x LTS stream, upgrade to 4.14.6 is recommended. For those on the 4.18.x stream, upgrade to 4.18.2 is advised. Red Hat provides updated builds addressing this vulnerability. Applying these updates will remediate the issue. No alternative mitigations or workarounds are indicated in the vendor advisory.

Description

The fix for CVE-2025-27636 added setLowerCase(true) to HttpHeaderFilterStrategy so that case-variant header names such as 'CAmelExecCommandExecutable' are filtered out alongside 'CamelExecCommandExecutable'. The same setLowerCase(true) call was not applied to five non-HTTP HeaderFilterStrategy implementations: JmsHeaderFilterStrategy and ClassicJmsHeaderFilterStrategy in camel-jms, SjmsHeaderFilterStrategy in camel-sjms, CoAPHeaderFilterStrategy in camel-coap, and GooglePubsubHeaderFilterStrategy in camel-google-pubsub. Because those strategies use case-sensitive String.startsWith('Camel'/'camel') filtering while the Camel Exchange stores headers in a case-insensitive map, an attacker with JMS (or equivalent) producer access to the broker consumed by a Camel route can inject case-variant Camel internal headers, which are then resolved by downstream components such as camel-exec and camel-file using their canonical casing. This enables remote code execution and arbitrary file write on routes that forward JMS messages to header-driven components. This issue affects Apache Camel: from 3.0.0 before 4.14.6, from 4.15.0 before 4.18.2, from 4.19.0 before 4.20.0. Users are recommended to upgrade to version 4.20.0, which fixes the issue. If users are on the 4.14.x LTS releases stream, then they are suggested to upgrade to 4.14.6. If users are on the 4.18.x releases stream, then they are suggested to upgrade to 4.18.2.

References

Community reviews

Loading reviews…