Skip to main content
VulnerabilityPublished

CVE-2026-40460: F5 NGINX Plus · Authentication Bypass by Spoofing

Affects F5 NGINX PlusSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 6.5 Medium : upgrade to 1.30.1 when convenient.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 3.1 base score
6.5Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 31% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.30.1
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:L

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 13 May 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade NGINX Open Source to 1.30.1.

Affected software

ProductAffectedFixed in
F5NGINX PlusAffected
  • =R36
  • =R32
Fixed in–
F5NGINX Open SourceAffected
  • >=1.26.0 <1.30.1
Fixed in
  • 1.30.1

AI-suggested

If you cannot patch yet, organizations should consider disabling the HTTP/3 QUIC module if feasible or implementing additional network-level controls to detect and block IP spoofing.

Description

When NGINX Plus or NGINX Open Source are configured to use the HTTP/3 QUIC module, an attacker may be able to spoof their source IP address allowing for bypass of authorization or bypass of rate limiting. Note: Software versions which have reached End of Technical Support (EoTS) are not evaluated.

References

Community reviews

Loading reviews…