CVE-2026-40489: editorconfig-core-c · Stack-based Buffer Overflow
Affects editorconfig-core-cSource CVE Database V5
Mentioned vulnerabilities
Not known to be exploited · CVSS 8.6 High : upgrade to 0.12.11 soon.
Data as of 30 Oct 2026, 06:59 UTC
- EPSS
- 0.1% chance of exploitation in 30 days – higher than 4% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 0.12.11
CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 18 Apr 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade editorconfig-core-c and editorconfig/editorconfig-core-c to 0.12.11.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| editorconfigeditorconfig-core-c | Affected
| Fixed in
|
GitHubeditorconfig/editorconfig-core-cpkg:github/editorconfig/editorconfig-core-cOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Version 0.12.11 of editorconfig-core-c contains the updated fix for this vulnerability. Users and developers should upgrade to version 0.12.11 or later to remediate this issue. No official remediation level or patch links are provided in the advisory, but the vendor has addressed the vulnerability in the stated version. Until upgrade, avoid processing untrusted .editorconfig files or directory structures with vulnerable versions. Patch status is not explicitly confirmed beyond the mention of version 0.12.11 containing the fix; verify with vendor sources for the latest guidance.
Description
editorconfig-core-c is an EditorConfig core library for use by plugins supporting EditorConfig parsing. Versions up to and including 0.12.10 have a stack-based buffer overflow in ec_glob() that allows an attacker to crash any application using libeditorconfig by providing a specially crafted directory structure and .editorconfig file. This is an incomplete fix for CVE-2023-0341. The pcre_str buffer was protected in 0.12.6 but the adjacent l_pattern[8194] stack buffer received no equivalent protection. On Ubuntu 24.04, FORTIFY_SOURCE converts the overflow to SIGABRT (DoS). Version 0.12.11 contains an updated fix.
References
- github.com/editorconfig/editorconfig-core-c/security/advisories/GHSA-97xg-vrcq-254h (opens in a new tab)
- github.com/editorconfig/editorconfig-core-c/commit/5159be88ad50641d9843289adda791ba300421ff (opens in a new tab)
- github.com/editorconfig/editorconfig-core-c/releases/tag/v0.12.11 (opens in a new tab)