Skip to main content
VulnerabilityPublished Updated

CVE-2026-40557: Apache Storm Prometheus Reporter · Improper Certificate Validation

Affects Apache Storm Prometheus ReporterSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 4.8 Medium : upgrade to 2.8.7 when convenient.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 3.1 base score
4.8Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.1% chance of exploitation in 30 days – higher than 9% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2.8.7
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 27 Apr 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade Apache to 2.8.7.

Affected software

ProductAffectedFixed in
Apache Software FoundationApache Storm Prometheus ReporterAffected
  • >=2.6.3 <2.8.7
Fixed in
  • 2.8.7
Mavenorg.apache.storm/stormpkg:maven/org.apache.storm/stormOther threatsAffected
  • =2.6.3
  • <=2.8.6
Fixed in–
MavenApache Software Foundation/org.apache.storm:storm-metrics-prometheuspkg:maven/Apache Software Foundation/org.apache.storm:storm-metrics-prometheusOther threatsAffected
  • >=2.6.3 <2.8.7
Fixed in
  • 2.8.7

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available in Apache Storm version 2.8.7. Users of affected versions who utilize the Prometheus Metrics Reporter should upgrade to 2.8.7. If immediate upgrade is not possible, users must remove the configuration setting storm.daemon.metrics.reporter.plugin.prometheus.skip_tls_validation: true from their storm.yaml file and instead configure a proper truststore containing the PushGateway's certificate to ensure secure TLS validation.

Description

Improper Certificate Validation via Global SSL Context Downgrade in Apache Storm Prometheus Reporter Versions Affected: from 2.6.3 to 2.8.6 Description:  In production deployments where an administrator enables storm.daemon.metrics.reporter.plugin.prometheus.skip_tls_validation (by default it is disabled) intending to affect only the Prometheus reporter, the undocumented global side effect creates an attack surface across every TLS-protected communication channel in the Storm daemon. The PrometheusPreparableReporter class implements an INSECURE_TRUST_MANAGER that accepts all SSL certificates without validation, with empty checkClientTrusted and checkServerTrusted methods. Most critically, when the storm.daemon.metrics.reporter.plugin.prometheus.skip_tls_validation configuration option is enabled (default = disabled) for HTTPS Prometheus PushGateway connections, the INSECURE_CONNECTION_FACTORY calls SSLContext.setDefault(sslContext), which globally replaces the JVM's default SSL context rather than applying the insecure context only to the Prometheus connection. This payload flows through storm.yaml configuration → PrometheusPreparableReporter.prepare() → INSECURE_CONNECTION_FACTORY → SSLContext.setDefault(), resulting in a JVM-wide TLS security downgrade. All subsequent HTTPS connections in the process - including ZooKeeper, Thrift, Netty, and UI connections - silently trust all certificates, including self-signed, expired, and attacker-generated ones, enabling man-in-the-middle interception of cluster state, topology submissions, tuple data, and administrative credentials. Mitigation: 2.x users should upgrade to 2.8.7 if the Prometheus Metrics Reporter is used. Prometheus Metrics Reporter Users who cannot upgrade immediately should remove the storm.daemon.metrics.reporter.plugin.prometheus.skip_tls_validation: true setting from their storm.yaml configuration and instead configure a proper truststore containing the PushGateway's certificate.

References

Community reviews

Loading reviews…