CVE-2026-40563: Apache Atlas · Code Injection
Affects Apache AtlasSource CVE Database V5
Not known to be exploited · CVSS 8.1 High · fixed in 2.5.0 : patch Apache Atlas soon.
Data as of 31 Oct 2026, 20:20 UTC
- EPSS
- 0.4% chance of exploitation in 30 days – higher than 40% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 2.5.0
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:NExploitation evidence
Disclosed: evidence found.
CVE published 4 May 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 31 Oct 2026.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Apache Software FoundationApache Atlas | Affected
| Fixed in– |
Mavenorg.apache.atlas/atlaspkg:maven/org.apache.atlas/atlasOther threats | Affected
| Fixed in– |
MavenApache Software Foundation/org.apache.atlas:atlas-repositorypkg:maven/Apache Software Foundation/org.apache.atlas:atlas-repositoryOther threats | Affected
| Fixed in– |
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Users should upgrade Apache Atlas to version 2.5.0, which addresses this vulnerability. For versions 2.0 and above, ensure that the configuration 'atlas.dsl.executor.traversal' is not set to false to avoid exposure. Patch status is not explicitly confirmed in the vendor advisory, but upgrading to 2.5.0 is the recommended fix.
Description
Description: Improper Control of Generation of Code ('Code Injection') vulnerability in Apache Atlas Apache Atlas exposes a DSL search endpoint that accepts user-supplied query strings. Attacker can alter Gremlin traversal logic within grammar-allowed characters to access unintended data Affect Version: This issue affects Apache Atlas: from 0.8 through 2.4.0. For the affect version >= 2.0, vulnerability is only when Atlas is deployed with below non-default configuration.atlas.dsl.executor.traversal=false Mitigation: Users are recommended to upgrade to version 2.5.0, which fixes the issue.