CVE-2026-40588: blueprintue-self-hosted-edition · Unverified Password Change
Affects blueprintue-self-hosted-editionSource CVE Database V5
Not known to be exploited · CVSS 8.1 High : upgrade to 4.2.0 soon.
Data as of 30 Oct 2026, 11:52 UTC
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 18% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 4.2.0
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:NExploitation evidence
Disclosed: evidence found.
CVE published 21 Apr 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade blueprintue-self-hosted-edition and blueprintue/blueprintue-self-hosted-edition to 4.2.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| blueprintueblueprintue-self-hosted-edition | Affected
| Fixed in
|
GitHubblueprintue/blueprintue-self-hosted-editionpkg:github/blueprintue/blueprintue-self-hosted-editionOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade blueprintue-self-hosted-edition to version 4.2.0 or later, where this vulnerability is fixed. Until upgrading, restrict access to authenticated sessions and protect session tokens to prevent unauthorized access. Patch status is not explicitly stated in vendor advisories but the fix is included in version 4.2.0.
Description
CVE-2026-40588 is a high-severity vulnerability in blueprintue-self-hosted-edition versions prior to 4.2.0. The password change form does not require verification of the current password, allowing an attacker with an authenticated session to change the password without knowing the original. This can lead to permanent account takeover. The vulnerability is fixed in version 4.2.0. No known exploits are reported in the wild.