CVE-2026-40602: home-assistant-cli · Code Injection
Affects home-assistant-cliSource CVE Database V5
Not known to be exploited · CVSS 5.6 Medium : upgrade to 1.0.0 when convenient.
Data as of 30 Oct 2026, 11:52 UTC
- EPSS
- 0.1% chance of exploitation in 30 days – higher than 0% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 1.0.0
CVSS:3.1/AV:L/AC:H/PR:H/UI:R/S:U/C:H/I:H/A:NExploitation evidence
Disclosed: evidence found.
CVE published 21 Apr 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade home-assistant-cli to 1.0.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| home-assistant-ecosystemhome-assistant-cli | Affected
| Fixed in
|
PyPIhome-assistant-clipkg:pypi/home-assistant-cliOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade home-assistant-cli to version 1.0.0 or later, where this vulnerability is fixed by sandboxing Jinja2 template rendering. No other mitigations are indicated or necessary once the update is applied.
Description
The Home Assistant Command-line interface (hass-cli) is a command-line tool for Home Assistant. Up to 1.0.0 of home-assitant-cli an unrestricted environment was used to handle Jninja2 templates instead of a sandboxed one. The user-supplied input within Jinja2 templates was rendered locally with no restrictions. This gave users access to Python's internals and extended the scope of templating beyond the intended usage. This vulnerability is fixed in 1.0.0.