CVE-2026-40611: go-acme lego · Path Traversal
Affects go-acme legoSource CVE Database V5
Not known to be exploited · CVSS 8.8 High : upgrade to 4.34.0 soon.
Data as of 30 Oct 2026, 06:59 UTC
- EPSS
- 0.4% chance of exploitation in 30 days – higher than 36% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 4.34.0
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 21 Apr 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade lego and github.com/go-acme/lego to 4.34.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| go-acmelego | Affected
| Fixed in
|
Gogithub.com/go-acme/legopkg:golang/github.com/go-acme/legoOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A fix is available in go-acme lego version 4.34.0. Users should upgrade to version 4.34.0 or later to remediate this vulnerability. Patch status is confirmed by the vendor advisory. No alternative mitigations are documented.
Description
Let's Encrypt client and ACME library written in Go (Lego). Prior to 4.34.0, the webroot HTTP-01 challenge provider in lego is vulnerable to arbitrary file write and deletion via path traversal. A malicious ACME server can supply a crafted challenge token containing ../ sequences, causing lego to write attacker-influenced content to any path writable by the lego process. This vulnerability is fixed in 4.34.0.
References
- github.com/go-acme/lego/security/advisories/GHSA-qqx8-2xmm-jrv8 (opens in a new tab)
- access.redhat.com/security/cve/CVE-2026-40611 (opens in a new tab)
- bugzilla.redhat.com/show_bug.cgi?id=2460233 (opens in a new tab)
- security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-40611.json (opens in a new tab)
- access.redhat.com/errata/RHSA-2026:21772 (opens in a new tab)