Skip to main content
VulnerabilityPublished Updated

CVE-2026-40641: Dell PowerFlex · Weak Cryptography

Affects Dell PowerFlexSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 4.8 Medium : upgrade to 5.1.0.1 or later or 4.5.5.2 or later when convenient.

Data as of 30 Oct 2026, 20:25 UTC

CVSS 3.1 base score
4.8Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.1% chance of exploitation in 30 days – higher than 0% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 5.1.0.1 or later, 4.5.5.2 or later
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 17 Jun 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade Dell PowerFlex to 5.1.0.1 or later or 4.5.5.2 or later.

Affected software

ProductAffectedFixed in
DellPowerFlexAffected
  • =0
Fixed in
  • 5.1.0.1 or later
  • 4.5.5.2 or later

AI-suggested

Avoid relying on the affected versions in sensitive environments until a fix is available.

Description

Dell PowerFlex Manager, version(s) prior to 5.1.0.1, contain(s) an Use of a Broken or Risky Cryptographic Algorithm vulnerability. An unauthenticated attacker with remote access could potentially exploit this vulnerability, leading to Information disclosure and Information tampering.

References

Community reviews

Loading reviews…