Skip to main content
VulnerabilityPublished Updated

CVE-2026-40684: Exim · Incorrect Provision of Specified Functionality

Affects EximSource GCVE Database

0

Not known to be exploited · CVSS 5.9 Medium : upgrade to 4.99.2 when convenient.

Data as of 27 Oct 2026, 00:43 UTC

CVSS 3.1 base score
5.9Medium
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 4.99.2
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 30 Apr 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade Exim to 4.99.2.

Affected software

ProductAffectedFixed in
Exim EximAffected
  • <4.99.2
Fixed in
  • 4.99.2

AI-suggested

A fix is available in Exim version 4.99.2 and later. Users should upgrade to version 4.99.2 or newer to remediate this vulnerability. No other mitigation or workaround is indicated.

Description

CVE-2026-40684 is a vulnerability in Exim versions before 4.99.2 affecting systems using musl libc. It allows an attacker to crash the connection instance by sending malformed DNS PTR records due to an issue in dn_expand's octal printing. This results in a denial of service without impacting confidentiality or integrity.

References

Community reviews

Loading reviews…