Skip to main content
VulnerabilityPublished Updated

CVE-2026-40861: Apache Airflow · Link Following

Affects Apache AirflowSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 6.5 Medium : upgrade to 3.2.2 when convenient.

Data as of 29 Oct 2026, 19:04 UTC

CVSS 3.1 base score
6.5Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.6% chance of exploitation in 30 days – higher than 52% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 3.2.2
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 1 Jun 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade Apache Airflow and apache-airflow to 3.2.2.

Affected software

ProductAffectedFixed in
Apache Software FoundationApache AirflowAffected
  • <3.2.2
Fixed in
  • 3.2.2
PyPIapache-airflowpkg:pypi/apache-airflowOther threatsAffected
  • <3.2.2
Fixed in
  • 3.2.2

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade Apache Airflow to version 3.2.2 or later, where this vulnerability is fixed. Additionally, as a defense-in-depth measure, deploy the worker and API server with separate log volumes to prevent worker-controlled paths from reaching the API server's filesystem. Patch status is confirmed by the vendor advisory recommending upgrade to 3.2.2.

Description

CVE-2026-40861 is a medium severity vulnerability in Apache Airflow prior to version 3.2.2. It involves improper link resolution before file access, allowing a DAG author to cause the FileTaskHandler to read or overwrite arbitrary files outside the intended log directory. This occurs when the worker log folder is shared with the API server. The vulnerability can lead to sensitive file disclosure but does not affect availability or integrity directly.

References

Community reviews

Loading reviews…