CVE-2026-40903: patrickhener goshs · Untrusted Functionality Inclusion
Affects patrickhener goshsSource CVE Database V5
Not known to be exploited · CVSS 9.1 Critical : upgrade to 2.0.0-beta.6 as a priority.
Data as of 30 Oct 2026, 11:52 UTC
Contested
Critical score, yet low EPSS after six months- EPSS
- 0.2% chance of exploitation in 30 days – higher than 15% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 2.0.0-beta.6
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:NExploitation evidence
Disclosed: evidence found.
CVE published 21 Apr 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade patrickhener goshs to 2.0.0-beta.6.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| patrickhenergoshs | Affected
| Fixed in
|
Gogithub.com/patrickhener/goshspkg:golang/github.com/patrickhener/goshsOther threats | Affected
| Fixed in– |
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
The vulnerability is fixed in goshs version 2.0.0-beta.6. Users should upgrade to this version or later to remediate the issue.
Description
The goshs SimpleHTTPServer written in Go versions prior to 2.0.0-beta.6 contains a critical vulnerability (CVE-2026-40903) involving inclusion of functionality from an untrusted control sphere. This vulnerability, classified as CWE-829, can cause leakage of the GITHUB_TOKEN through workflow artifacts despite the token not being present in the repository source code. The issue is fixed starting from version 2.0.0-beta.6. The vulnerability has a high CVSS score of 9.