Skip to main content
VulnerabilityPublished Updated

CVE-2026-40906: electric · SQL Injection

Affects electricSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 10.0 Critical : upgrade to 1.5.0 as a priority.

Data as of 29 Oct 2026, 19:04 UTC

CVSS 3.1 base score
10.0Critical
How severe the flaw is on the 0–10 CVSS scale.

Contested

Critical score, yet low EPSS after six months
EPSS
0.4% chance of exploitation in 30 days – higher than 39% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.5.0
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 21 Apr 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade electric and electric-sql/electric to 1.5.0.

Affected software

ProductAffectedFixed in
electric-sqlelectricAffected
  • >=1.1.12 <1.5.0
Fixed in
  • 1.5.0
GitHubelectric-sql/electricpkg:github/electric-sql/electricOther threatsAffected
  • <1.5.0 >=1.1.12
Fixed in
  • 1.5.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available in ElectricSQL version 1.5.0. Users should upgrade to version 1.5.0 or later to remediate this vulnerability. No vendor advisory indicates alternative mitigations or that no action is required.

Description

Electric is a Postgres sync engine. From 1.1.12 to before 1.5.0, the order_by parameter in the ElectricSQL /v1/shape API is vulnerable to error-based SQL injection, allowing any authenticated user to read, write, and destroy the full contents of the underlying PostgreSQL database through crafted ORDER BY expressions. This vulnerability is fixed in 1.5.0.

References

Community reviews

Loading reviews…