Skip to main content
VulnerabilityPublished

CVE-2026-40944: oxia · Improper Certificate Validation

Affects oxiaSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 6.9 Medium : upgrade to 0.16.2 when convenient.

Data as of 30 Oct 2026, 06:59 UTC

CVSS 4.0 base score
6.9Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.1% chance of exploitation in 30 days – higher than 5% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 0.16.2
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 21 Apr 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade oxia and oxia-db/oxia to 0.16.2.

Affected software

ProductAffectedFixed in
oxia-dboxiaAffected
  • <0.16.2
Fixed in
  • 0.16.2
GitHuboxia-db/oxiapkg:github/oxia-db/oxiaOther threatsAffected
  • <0.16.2
Fixed in
  • 0.16.2

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade oxia to version 0.16.2 or later, where the trustedCertPool() function correctly parses all PEM blocks in CA certificate files, restoring proper certificate chain validation. Patch status is confirmed by the vendor fix in version 0.16.2. No other mitigations are indicated.

Description

CVE-2026-40944 is a medium severity vulnerability in oxia versions prior to 0.16.2 where the trustedCertPool() function only parses the first PEM block from CA certificate files. This causes incomplete loading of CA bundles containing multiple certificates, breaking certificate chain validation for mutual TLS (mTLS). The issue is fixed in version 0.16.2.

References

Community reviews

Loading reviews…