CVE-2026-40945: oxia · Sensitive Data in Logs
Affects oxiaSource CVE Database V5
Not known to be exploited · CVSS 8.7 High : upgrade to 0.16.2 soon.
Data as of 30 Oct 2026, 06:59 UTC
- EPSS
- 0.3% chance of exploitation in 30 days – higher than 23% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 0.16.2
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 21 Apr 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade oxia and oxia-db/oxia to 0.16.2.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| oxia-dboxia | Affected
| Fixed in
|
GitHuboxia-db/oxiapkg:github/oxia-db/oxiaOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade oxia to version 0.16.2 or later, where this vulnerability is fixed. Until the upgrade, avoid enabling DEBUG level logging in production environments to prevent sensitive token exposure. Patch status is not explicitly stated but the fix is included in version 0.16.2, so applying this official fix is the recommended remediation.
Description
CVE-2026-40945 is a vulnerability in oxia-db's oxia metadata store and coordination system where, prior to version 0.16.2, failed OIDC authentication attempts cause the full bearer token to be logged in plaintext at DEBUG level. This exposes sensitive JWT tokens in application logs and any connected log aggregation systems if debug logging is enabled in production environments. The vulnerability has a high severity with a CVSS score of 8.7. It is fixed starting from version 0.16.2.