CVE-2026-40970: Spring Boot · Improper Certificate Validation
Affects Spring BootSource CVE Database V5
Not known to be exploited · CVSS 5.0 Medium : upgrade to 4.0.6 when convenient.
Data as of 30 Oct 2026, 11:52 UTC
- EPSS
- 0.1% chance of exploitation in 30 days – higher than 2% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 4.0.6
CVSS:3.1/AV:A/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:LExploitation evidence
Disclosed: evidence found.
CVE published 27 Apr 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade Spring Boot to 4.0.6.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| SpringSpring Boot | Affected
| Fixed in
|
Mavenorg.springframework.boot/spring-bootpkg:maven/org.springframework.boot/spring-bootOther threats | Affected
| Fixed in– |
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade affected Spring Boot versions from 4.0.0–4.0.5 to version 4.0.6 or later as recommended by the vendor. Patch status is confirmed by the vendor advisory indicating an official fix is available in version 4.0.6. No additional mitigations are specified.
Description
When configured to use an SSL bundle, Spring Boot's Elasticsearch auto-configuration does not perform hostname verification when connecting to the Elasticsearch server. Affected: Spring Boot 4.0.0–4.0.5; upgrade to 4.0.6 or later per vendor advisory.