CVE-2026-40976: Spring Boot · Missing Authorization
Affects Spring BootSource CVE Database V5
Not known to be exploited · CVSS 9.1 Critical : upgrade to 4.0.6 as a priority.
Data as of 30 Oct 2026, 11:52 UTC
Contested
Critical score, yet low EPSS after six months- EPSS
- 0.4% chance of exploitation in 30 days – higher than 42% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 4.0.6
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:NExploitation evidence
Disclosed: evidence found.
CVE published 27 Apr 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: evidence found.
Public exploit code: GitHub proofs of concept
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), GitHub proofs of concept, the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade Spring Boot to 4.0.6.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| SpringSpring Boot | Affected
| Fixed in
|
Mavenorg.springframework.boot/spring-bootpkg:maven/org.springframework.boot/spring-bootOther threats | Affected
| Fixed in– |
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A fix is available by upgrading to Spring Boot version 4.0.6 or later as per the vendor advisory. Applications should verify their Spring Security configurations and avoid relying solely on the default security filter chain if they depend on spring-boot-actuator-autoconfigure and do not depend on spring-boot-health. Consult the Red Hat advisory at https://access.redhat.com/security/cve/CVE-2026-40976 for detailed remediation guidance.
Description
In certain circumstances, Spring Boot's default web security is ineffective allowing unauthorized access to all endpoints. For an application to be vulnerable, it must: be a servlet-based web application; have no Spring Security configuration of its own and rely on the default web security filter chain; depend on spring-boot-actuator-autoconfigure; not depend on spring-boot-health. If any of the above does not apply, the application is not vulnerable. Affected: Spring Boot 4.0.0–4.0.5; upgrade to 4.0.6 or later per vendor advisory.