CVE-2026-40978: Spring AI · SQL Injection
Affects Spring AISource CVE Database V5
Not known to be exploited · CVSS 8.8 High : upgrade to 1.1.5 or 1.0.6 soon.
Data as of 30 Oct 2026, 11:52 UTC
- EPSS
- 0.3% chance of exploitation in 30 days – higher than 27% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 1.1.5, 1.0.6
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 28 Apr 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade Spring AI to 1.1.5 or 1.0.6.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| SpringSpring AI | Affected
| Fixed in
|
| SpringSpring AI | Affected
| Fixed in
|
AI-suggested
Upgrade affected Spring AI instances to version 1.0.6 or later, or 1.1.5 or later, where this vulnerability is fixed. Since no official vendor advisory or patch link is provided, verify the upgrade through official Spring AI release notes or vendor channels. Until patched, restrict access to the affected components and validate or sanitize document IDs to reduce risk.
Description
CVE-2026-40978 is a high-severity SQL injection vulnerability in the CosmosDBVectorStore component of Spring AI versions 1.0.0 through 1.0.5 and 1.1.0 through 1.1.4. This flaw allows attackers with limited privileges to execute arbitrary SQL commands by leveraging crafted document IDs.