CVE-2026-41007: Spring HATEOAS · Unthrottled Resource Allocation
Affects Spring HATEOASSource CVE Database V5
Not known to be exploited · CVSS 7.5 High · fixed in 3.0.3.1 : patch Spring HATEOAS soon.
Data as of 30 Oct 2026, 06:59 UTC
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 22% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 3.0.3.1, 2.5.2.1, 2.4.2 +2
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:HExploitation evidence
Disclosed: evidence found.
CVE published 9 Jun 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade to a fixed release listed under Affected software.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| SpringSpring HATEOAS | Affected
| Fixed in
|
| SpringSpring HATEOAS | Affected
| Fixed in
|
| SpringSpring HATEOAS | Affected
| Fixed in
|
| SpringSpring HATEOAS | Affected
| Fixed in
|
| SpringSpring HATEOAS | Affected
| Fixed in
|
Mavenorg.springframework.hateoas/spring-hateoaspkg:maven/org.springframework.hateoas/spring-hateoasOther threats | Affected
| Fixed in– |
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
If you cannot patch yet, consider implementing external rate limiting or input validation to limit attacker-supplied strings that could cause unbounded cache growth.
Description
CVE-2026-41007 is a high-severity vulnerability in Spring HATEOAS where an unbounded static cache of StringLinkRelation instances is maintained using attacker-supplied strings. This affects multiple versions from 1.5.0 through 3.0.3. The vulnerability can lead to resource exhaustion due to allocation without limits or throttling.