Skip to main content
VulnerabilityPublished Updated

CVE-2026-41017: Apache Airflow · Sensitive Cookie in HTTPS Session Without 'Secure' Attribute

Affects Apache AirflowSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 5.9 Medium : upgrade to 3.2.2 when convenient.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 3.1 base score
5.9Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 28% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 3.2.2
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 1 Jun 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade Apache Airflow to 3.2.2.

Affected software

ProductAffectedFixed in
Apache Software FoundationApache AirflowAffected
  • >=3.0.0 <3.2.2
Fixed in
  • 3.2.2
PyPIapache-airflowpkg:pypi/apache-airflowOther threatsAffected
  • =3.0.0
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Users should upgrade Apache Airflow to version 3.2.2 or later, where this issue is fixed by setting the Secure attribute on the JWT authentication cookie. Until upgrade, ensure that all traffic to the Airflow API server is strictly HTTPS and that no HTTP requests can be made to the same hostname to prevent cookie leakage. Patch status is not explicitly stated in the vendor advisory, but the recommendation to upgrade to 3.2.2 or later indicates an official fix is available in those versions.

Description

Apache Airflow version 3.0.0 has a vulnerability where the JWT authentication cookie is set without the Secure attribute. This affects deployments where the Airflow API server is behind an HTTPS-terminating reverse proxy that forwards plaintext HTTP traffic to the server. An attacker positioned on the network could capture the JWT cookie if a user’s browser sends an HTTP request to the same host, allowing session replay attacks. Users are advised to upgrade to version 3.2.2 or later to address this issue.

References

Community reviews

Loading reviews…