CVE-2026-41018: Apache Airflow Providers Elasticsearch · Sensitive Data in Logs
Affects Apache Airflow Providers ElasticsearchSource CVE Database V5
Not known to be exploited · CVSS 6.5 Medium : upgrade to 6.5.3 when convenient.
Data as of 30 Oct 2026, 11:52 UTC
- EPSS
- 0.4% chance of exploitation in 30 days – higher than 35% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 6.5.3
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:NExploitation evidence
Disclosed: evidence found.
CVE published 11 May 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade Apache Airflow Providers Elasticsearch and apache-airflow-providers-elasticsearch to 6.5.3.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Apache Software FoundationApache Airflow Providers Elasticsearch | Affected
| Fixed in
|
PyPIapache-airflow-providers-elasticsearchpkg:pypi/apache-airflow-providers-elasticsearchOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Users should upgrade to apache-airflow-providers-elasticsearch version 6.5.3 or later where this issue is fixed. Additionally, as a defense-in-depth measure, credentials should not be embedded directly in the Elasticsearch host URL but configured via a secret backend. Patch status is not explicitly confirmed in the advisory, but the upgrade recommendation indicates a fix is available in 6.5.3+.
Description
CVE-2026-41018 is a vulnerability in the Apache Airflow Providers Elasticsearch logging integration where credentials embedded in the Elasticsearch host URL are written in full to task logs. This exposure allows any user with permission to read task logs to access sensitive backend credentials. The vulnerability has a medium severity with a CVSS score of 6.5. Users are advised to upgrade to version 6.5.3 or later and to avoid embedding credentials directly in the host URL by using a secret backend configuration instead.