Skip to main content
VulnerabilityPublished

CVE-2026-41032: Phoenix Contact CHARX SEC-3150 · Information Exposure

Affects Phoenix Contact CHARX SEC-3150Source CVE Database V5

0
Compare

Not known to be exploited · CVSS 7.5 High : upgrade to 1.9.0 soon.

Data as of 29 Oct 2026, 19:04 UTC

CVSS 3.1 base score
7.5High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 17% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.9.0
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 3 Jun 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade CHARX to 1.9.0.

Affected software

ProductAffectedFixed in
Phoenix ContactCHARX SEC-3150Affected
  • >=1.0.0 <1.9.0
Fixed in
  • 1.9.0
Phoenix ContactCHARX SEC-3100Affected
  • >=1.0.0 <1.9.0
Fixed in
  • 1.9.0
Phoenix ContactCHARX SEC-3050Affected
  • >=1.0.0 <1.9.0
Fixed in
  • 1.9.0
Phoenix ContactCHARX SEC-3000Affected
  • >=1.0.0 <1.9.0
Fixed in
  • 1.9.0

AI-suggested

If you cannot patch yet, restrict network access to the device to trusted and authenticated users only, especially limiting adjacent network access.

Description

CVE-2026-41032 is a vulnerability in the Phoenix Contact CHARX SEC-3150 controller that allows an unauthenticated adjacent attacker to download log files. These log files may contain restricted sensitive information. The vulnerability affects versions from 1.0.0 up to but not including 1.9.0. It has a high severity with a CVSS score of 7.5.

References

Community reviews

Loading reviews…