CVE-2026-41043: Apache ActiveMQ · Cross-site Scripting
Affects Apache ActiveMQSource CVE Database V5
Not known to be exploited · CVSS 6.5 Medium : upgrade to 6.2.5 or 5.19.6 when convenient.
Data as of 30 Oct 2026, 11:52 UTC
- EPSS
- 0.5% chance of exploitation in 30 days – higher than 46% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 6.2.5, 5.19.6
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:NExploitation evidence
Disclosed: evidence found.
CVE published 24 Apr 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade Apache ActiveMQ and Apache ActiveMQ Web and org.apache.activemq/activemq and Apache Software Foundation/org.apache.activemq:apache-activemq and Apache Software Foundation/org.apache.activemq:activemq-web to 6.2.5 or 5.19.6.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Apache Software FoundationApache ActiveMQ | Affected
| Fixed in
|
| Apache Software FoundationApache ActiveMQ | Affected
| Fixed in
|
| Apache Software FoundationApache ActiveMQ Web | Affected
| Fixed in
|
| Apache Software FoundationApache ActiveMQ Web | Affected
| Fixed in
|
Mavenorg.apache.activemq/activemqpkg:maven/org.apache.activemq/activemqOther threats | Affected
| Fixed in
|
MavenApache Software Foundation/org.apache.activemq:apache-activemqpkg:maven/Apache Software Foundation/org.apache.activemq:apache-activemqOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Users should upgrade Apache ActiveMQ to version 5.19.6 or 6.2.5 or later, where this vulnerability has been fixed. Patch status is confirmed by the vendor's recommendation to upgrade to these versions. No other mitigations or temporary fixes are indicated.
Description
CVE-2026-41043 is a medium severity cross-site scripting (XSS) vulnerability in Apache ActiveMQ and its web console. An authenticated attacker can inject malicious HTML content by overriding the content type and injecting HTML into a JMS selector field when browsing queues. This vulnerability affects Apache ActiveMQ versions before 5.19.6 and from 6.0.0 before 6.2.5. The issue allows limited impact on confidentiality and integrity but does not affect availability.