CVE-2026-41067: withastro astro · Cross-site Scripting
Affects withastro astroSource CVE Database V5
Not known to be exploited · CVSS 6.1 Medium : upgrade to 6.1.6 when convenient.
Data as of 30 Oct 2026, 11:52 UTC
- EPSS
- 0.1% chance of exploitation in 30 days – higher than 8% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 6.1.6
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:NExploitation evidence
Disclosed: evidence found.
CVE published 24 Apr 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade withastro astro to 6.1.6.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| withastroastro | Affected
| Fixed in
|
npmastropkg:npm/astroOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A fix is available in Astro version 6.1.6. Users and administrators should upgrade to version 6.1.6 or later to remediate this vulnerability. No other official remediation or temporary fixes are documented. Patch status is confirmed by the vendor advisory indicating the issue is fixed in 6.1.6.
Description
CVE-2026-41067 is a cross-site scripting (XSS) vulnerability in the Astro web framework versions prior to 6.1.6. The issue arises from improper sanitization in the defineScriptVars function, which uses a case-sensitive regex to sanitize inline <script> tag injections. Because HTML parsers treat script tag closures case-insensitively and accept variations with whitespace or slashes, attackers can bypass this sanitization and inject arbitrary HTML or JavaScript. This vulnerability has a CVSS score of 6.1 (medium severity) and is fixed in version 6.1.6.