Skip to main content
VulnerabilityPublished Updated

CVE-2026-41075: bestpractical rt · SQL Injection

Affects bestpractical rtSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 8.8 High : upgrade to 6.0.3 or 5.0.10 soon.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 3.1 base score
8.8High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 27% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 6.0.3, 5.0.10
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 22 May 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade rt and bestpractical/rt to 6.0.3 or 5.0.10.

Affected software

ProductAffectedFixed in
bestpracticalrtAffected
  • >=6.0.0 <6.0.3
Fixed in
  • 6.0.3
bestpracticalrtAffected
  • >=5.0.0 <5.0.10
Fixed in
  • 5.0.10
GitHubbestpractical/rtpkg:github/bestpractical/rtOther threatsAffected
  • <5.0.10
  • >=5.0.0 <5.0.10
  • <6.0.3
  • >=6.0.0 <6.0.3
Fixed in
  • 5.0.10
  • 6.0.3

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available in RT versions 5.0.10 and 6.0.3. Users should upgrade to these or later versions to remediate the vulnerability. If immediate upgrading is not feasible, restrict RT account access to trusted users as a temporary workaround.

Description

RT is an open source, enterprise-grade issue and ticket tracking system. Versions 5.0.0 through 5.0.9 and 6.0.0 through 6.0.2 contain an SQL injection vulnerability. An authenticated user can craft input that is incorporated into database queries without proper validation, potentially allowing them to read or modify data in the RT database. This issue has been fixed in versions 5.0.10 and 6.0.3. If developers are unable to upgrade immediately, they can temporarily work around this issue by restricting RT account access to trusted users.

References

Community reviews

Loading reviews…