Skip to main content
VulnerabilityPublished Updated

CVE-2026-41076: bestpractical rt · Improper Authentication

Affects bestpractical rtSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 8.1 High : upgrade to 6.0.3 or 5.0.10 soon.

Data as of 29 Oct 2026, 19:04 UTC

CVSS 3.1 base score
8.1High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 33% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 6.0.3, 5.0.10
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 22 May 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade rt and bestpractical/rt to 6.0.3 or 5.0.10.

Affected software

ProductAffectedFixed in
bestpracticalrtAffected
  • >=6.0.0 <6.0.3
Fixed in
  • 6.0.3
bestpracticalrtAffected
  • <5.0.10
Fixed in
  • 5.0.10
GitHubbestpractical/rtpkg:github/bestpractical/rtOther threatsAffected
  • <5.0.10
  • >=6.0.0 <6.0.3
Fixed in
  • 5.0.10
  • 6.0.3

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available in RT versions 5.0.10 and 6.0.3. Upgrading to these or later versions is the recommended remediation. If upgrading immediately is not feasible, administrators should review and adjust their LDAP server's authentication policies to reject unauthenticated bind attempts, which can serve as a temporary workaround. Patch status is confirmed by the vendor advisory embedded in the description.

Description

RT is an open source, enterprise-grade issue and ticket tracking system. Versions 5.0.9 and prior in addition to 6.0.0 through 6.0.2 contain an authentication bypass vulnerability in RT installations that use LDAP/AD for user authentication. Under certain LDAP server configurations, an attacker may be able to authenticate as any LDAP-backed RT user without supplying valid credentials. This issue has been fixed in versions 5.0.10 and 6.0.3. If developers are unable to upgrade immediately, they can temporarily work around this issue by reviewing their LDAP server's authentication policy to ensure it rejects unauthenticated bind attempts. Upgrading RT remains the recommended fix.

References

Community reviews

Loading reviews…