CVE-2026-41079: OpenPrinting cups · Out-of-bounds Read
Affects OpenPrinting cupsSource CVE Database V5
Not known to be exploited · CVSS 4.3 Medium : upgrade to 2.4.17 when convenient.
Data as of 30 Oct 2026, 11:52 UTC
- EPSS
- 0.4% chance of exploitation in 30 days – higher than 35% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 2.4.17
CVSS:3.1/AV:A/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:NExploitation evidence
Disclosed: evidence found.
CVE published 24 Apr 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade cups and openprinting/cups to 2.4.17.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| OpenPrintingcups | Affected
| Fixed in
|
GitHubopenprinting/cupspkg:github/openprinting/cupsOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade OpenPrinting CUPS to version 2.4.17 or later, where this vulnerability is fixed. Since the vendor advisory confirms the fix in 2.4.17, applying this official update fully mitigates the issue. No other mitigations are indicated or required.
Description
CVE-2026-41079 is a medium severity vulnerability in OpenPrinting CUPS versions prior to 2.4.17. It involves an out-of-bounds read triggered by a crafted SNMP response sent to the CUPS SNMP backend. This flaw allows reading up to 176 bytes beyond a stack buffer, leaking memory that is converted to UTF-8 and exposed as printer supply descriptions. These leaked strings can be viewed by authenticated users through IPP Get-Printer-Attributes responses and the CUPS web interface. The vulnerability does not impact integrity or availability and requires network adjacency but no privileges or user interaction. A fix is available in version 2.4.17.