CVE-2026-41128: craftcms cms · Missing Authorization
Affects craftcms cmsSource CVE Database V5
Not known to be exploited · CVSS 5.3 Medium : upgrade to 5.9.15 when convenient.
Data as of 29 Oct 2026, 19:04 UTC
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 16% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 5.9.15
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 21 Apr 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade cms and craftcms/cms to 5.9.15.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| craftcmscms | Affected
| Fixed in
|
GitHubcraftcms/cmspkg:github/craftcms/cmsOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available in Craft CMS version 5.9.15 that addresses this missing authorization vulnerability. Users should upgrade to version 5.9.15 or later to remediate this issue.
Description
Craft CMS versions 5.6.0 through 5.9.14 contain a missing authorization vulnerability in the actionSavePermissions() endpoint. A user with only viewUsers permission can remove arbitrary users from all user groups because the system does not enforce authorization checks for group removals. This issue is patched in version 5.9.15.