CVE-2026-41140: poetry · Path Traversal
Affects poetrySource CVE Database V5
Not known to be exploited · CVSS 0.6 Low : upgrade to 2.3.4 when convenient.
Data as of 29 Oct 2026, 19:04 UTC
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 21% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 2.3.4
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:P/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N/E:UExploitation evidence
Disclosed: evidence found.
CVE published 24 Apr 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade poetry to 2.3.4.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| python-poetrypoetry | Affected
| Fixed in
|
PyPIpoetrypkg:pypi/poetryOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A fix is available in poetry version 2.3.4. Users should upgrade to version 2.3.4 or later to remediate this vulnerability. Red Hat provides advisories and updates addressing this issue for their affected products. Patch status is confirmed by vendor advisories. No additional mitigation steps are specified or required beyond applying the official fix.
Description
Poetry is a dependency manager for Python. Prior to 2.3.4, the extractall() function in src/poetry/utils/helpers.py:410-426 extracts sdist tarballs without path traversal protection on Python versions where tarfile.data_filter is unavailable. Considering only Python versions which are still supported by Poetry, these are 3.10.0 - 3.10.12 and 3.11.0 - 3.11.4. This vulnerability is fixed in 2.3.4.
References
- github.com/python-poetry/poetry/security/advisories/GHSA-73h3-mf4w-8647 (opens in a new tab)
- access.redhat.com/security/cve/CVE-2026-41140 (opens in a new tab)
- bugzilla.redhat.com/show_bug.cgi?id=2461604 (opens in a new tab)
- security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-41140.json (opens in a new tab)
- access.redhat.com/errata/RHSA-2026:24866 (opens in a new tab)