CVE-2026-41149: mermaid · Code Injection
Affects mermaidSource CVE Database V5
Not known to be exploited · CVSS 5.3 Medium : upgrade to 11.15.0 or 10.9.6 when convenient.
Data as of 29 Oct 2026, 19:04 UTC
- EPSS
- 0.4% chance of exploitation in 30 days – higher than 34% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 11.15.0, 10.9.6
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:L/VA:N/SC:L/SI:L/SA:LExploitation evidence
Disclosed: evidence found.
CVE published 22 May 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade mermaid and mermaid-js/mermaid to 11.15.0 or 10.9.6.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| mermaid-jsmermaid | Affected
| Fixed in
|
| mermaid-jsmermaid | Affected
| Fixed in
|
npmmermaid-js/mermaidpkg:npm/mermaid-js/mermaidOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A fix is available in mermaid versions 10.9.6 and 11.15.0. Users should upgrade to these or later versions to remediate the vulnerability. If immediate upgrading is not feasible, setting the configuration option "securityLevel" to "sandbox" provides a temporary workaround by rendering diagrams in a sandboxed iframe, preventing the injection issue.
Description
Mermaid is a JavaScript tool that uses Markdown-inspired text to create and modify diagrams and charts. Versions 10.9.5 and earlier, as well as 11.0.0-alpha.1 through 11.14.0, are vulnerable to HTML injection under the default configuration. Specifically, the classDef directive in Mermaid state diagrams permits DOM injection that escapes the SVG context. However, <script> tags are stripped, which prevents cross-site scripting (XSS). This issue has been fixed in versions 10.9.6 and 11.15.0. If developers are unable to immediately upgrade, they can work around this issue by setting "securityLevel": "sandbox", which prevents the issue by rendering the mermaid diagram in a sandboxed <iframe>.