CVE-2026-41163: containers bubblewrap · Improper Privilege Management
Affects containers bubblewrapSource CVE Database V5
Not known to be exploited · CVSS 8.7 High : upgrade to 0.11.2 soon.
Data as of 30 Oct 2026, 11:52 UTC
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 19% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 0.11.2
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 9 May 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade bubblewrap and containers/bubblewrap to 0.11.2.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| containersbubblewrap | Affected
| Fixed in
|
GitHubcontainers/bubblewrappkg:github/containers/bubblewrapOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A fix is available in bubblewrap version 0.11.2. Users and administrators should upgrade to version 0.11.2 or later to remediate this vulnerability. No vendor advisory indicates alternative mitigations or that no action is required.
Description
bubblewrap is a low-level unprivileged sandboxing tool. From version 0.11.0 to before version 0.11.2, if bubblewrap is installed in setuid mode then the user can use ptrace to attach to bubblewrap and control the unprivileged part of the sandbox setup phase. This allows the attacker to arbitrarily use the privileged operations, and in particular the "overlay mount" operation, allowing the creation of overlay mounts which is otherwise not allowed in the setuid version of bubblewrap. This issue has been patched in version 0.11.2.
References
- github.com/containers/bubblewrap/security/advisories/GHSA-xq78-7hw4-5jvp (opens in a new tab)
- github.com/containers/bubblewrap/releases/tag/v0.11.2 (opens in a new tab)
- access.redhat.com/security/cve/CVE-2026-41163 (opens in a new tab)
- bugzilla.redhat.com/show_bug.cgi?id=2468439 (opens in a new tab)
- security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-41163.json (opens in a new tab)