Skip to main content
VulnerabilityPublished

CVE-2026-41203: ci4-cms-erp ci4ms · Path Traversal

Affects ci4-cms-erp ci4msSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 9.4 Critical : upgrade to 0.31.5.0 as a priority.

Data as of 29 Oct 2026, 19:04 UTC

CVSS 4.0 base score
9.4Critical
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.6% chance of exploitation in 30 days – higher than 49% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 0.31.5.0
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 7 May 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade ci4ms and ci4-cms-erp/ci4ms to 0.31.5.0.

Affected software

ProductAffectedFixed in
ci4-cms-erpci4msAffected
  • <0.31.5.0
Fixed in
  • 0.31.5.0
GitHubci4-cms-erp/ci4mspkg:github/ci4-cms-erp/ci4msOther threatsAffected
  • <0.31.5.0
Fixed in
  • 0.31.5.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade ci4ms to version 0.31.5.0 or later, where this vulnerability has been patched. No other mitigation is indicated or required as the fix is official and addresses the root cause.

Description

CVE-2026-41203 is a critical path traversal vulnerability in the ci4ms product of the ci4-cms-erp project. The issue exists in versions prior to 0.31.5.0 where the Theme::upload function extracts user-uploaded ZIP archives without validating the entry names. This allows an authenticated backend user with theme create permission to write files to arbitrary filesystem locations, potentially leading to remote code execution by placing a PHP file under the public web root. The vulnerability has been patched in version 0.31.5.0.

References

Community reviews

Loading reviews…