CVE-2026-41239: cure53 DOMPurify · Cross-site Scripting
Affects cure53 DOMPurifySource CVE Database V5
Not known to be exploited · CVSS 6.8 Medium : upgrade to 3.4.0 when convenient.
Data as of 29 Oct 2026, 19:04 UTC
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 16% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 3.4.0
CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:NExploitation evidence
Disclosed: evidence found.
CVE published 23 Apr 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade DOMPurify and dompurify to 3.4.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| cure53DOMPurify | Affected
| Fixed in
|
npmdompurifypkg:npm/dompurifyOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade DOMPurify to version 3.4.0 or later, where this vulnerability is patched. Until upgrading, avoid using RETURN_DOM or RETURN_DOM_FRAGMENT modes with SAFE_FOR_TEMPLATES enabled in untrusted contexts. Patch status is not explicitly stated beyond the version 3.4.0 fix; check the vendor's advisory for the latest remediation guidance.
Description
DOMPurify is a DOM-only cross-site scripting sanitizer for HTML, MathML, and SVG. Starting in version 1.0.10 and prior to version 3.4.0, `SAFE_FOR_TEMPLATES` strips `{{...}}` expressions from untrusted HTML. This works in string mode but not with `RETURN_DOM` or `RETURN_DOM_FRAGMENT`, allowing XSS via template-evaluating frameworks like Vue 2. Version 3.4.0 patches the issue.