CVE-2026-41246: projectcontour contour · Code Injection
Affects projectcontour contourSource CVE Database V5
Not known to be exploited · CVSS 8.1 High · fixed in 1.33.4 : patch projectcontour contour soon.
Data as of 30 Oct 2026, 11:52 UTC
- EPSS
- 0.4% chance of exploitation in 30 days – higher than 42% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 1.33.4, 1.32.5, 1.31.6
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:HExploitation evidence
Disclosed: evidence found.
CVE published 23 Apr 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade contour and projectcontour/contour to 1.33.4, 1.32.5 or 1.31.6.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| projectcontourcontour | Affected
| Fixed in
|
| projectcontourcontour | Affected
| Fixed in
|
| projectcontourcontour | Affected
| Fixed in
|
GitHubprojectcontour/contourpkg:github/projectcontour/contourOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Fixed versions of Contour are 1.31.6, 1.32.5, and 1.33.4. Users should upgrade to one of these versions to remediate the vulnerability. The vendor advisory does not indicate any temporary mitigations or that no action is required. Therefore, upgrading to a fixed version is the recommended remediation.
Description
Contour is a Kubernetes ingress controller using Envoy proxy. From v1.19.0 to before v1.33.4, v1.32.5, and v1.31.6, Contour's Cookie Rewriting feature is vulnerable to Lua code injection. An attacker with RBAC permissions to create or modify HTTPProxy resources can craft a malicious value in spec.routes[].cookieRewritePolicies[].pathRewrite.value or spec.routes[].services[].cookieRewritePolicies[].pathRewrite.value that results in arbitrary code execution in the Envoy proxy. The cookie rewriting feature is internally implemented using Envoy's HTTP Lua filter. User-controlled values are interpolated into Lua source code using Go text/template without sufficient sanitization. The injected code only executes when processing traffic on the attacker's own route, which they already control. However, since Envoy runs as shared infrastructure, the injected code can also read Envoy's xDS client credentials from the filesystem or cause denial of service for other tenants sharing the Envoy instance. This vulnerability is fixed in v1.33.4, v1.32.5, and v1.31.6.
References
- github.com/projectcontour/contour/security/advisories/GHSA-x4mj-7f9g-29h4 (opens in a new tab)
- github.com/projectcontour/contour/releases/tag/v1.31.6 (opens in a new tab)
- github.com/projectcontour/contour/releases/tag/v1.32.5 (opens in a new tab)
- github.com/projectcontour/contour/releases/tag/v1.33.4 (opens in a new tab)
- access.redhat.com/security/cve/CVE-2026-41246 (opens in a new tab)
- bugzilla.redhat.com/show_bug.cgi?id=2461257 (opens in a new tab)
- security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-41246.json (opens in a new tab)