CVE-2026-41265: FlowiseAI Flowise · Command Injection
Affects FlowiseAI FlowiseSource CVE Database V5
Not known to be exploited · CVSS 9.2 Critical : upgrade to 3.1.0 as a priority.
Data as of 30 Oct 2026, 11:52 UTC
Contested
Critical score, yet low EPSS after six months- EPSS
- 0.5% chance of exploitation in 30 days – higher than 47% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 3.1.0
CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 23 Apr 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade Flowise and flowiseai/Flowise to 3.1.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| FlowiseAIFlowise | Affected
| Fixed in
|
GitHubflowiseai/Flowisepkg:github/flowiseai/FlowiseOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade Flowise to version 3.1.0 or later, where this vulnerability is fixed. Until upgraded, restrict access to the Airtable Agent node to trusted users only, if possible. Monitor for suspicious activity related to prompt injection attempts. Patch status is confirmed fixed in version 3.1.0.
Description
CVE-2026-41265 is a critical command injection vulnerability in FlowiseAI's Flowise product versions prior to 3.1.0. The flaw exists in the run method of the Airtable_Agents class, where an LLM-generated Python script is evaluated without proper sandboxing. An unauthenticated attacker can use prompt injection to cause the LLM to generate and execute malicious Python code on the server. This vulnerability allows remote code execution with high impact on confidentiality, integrity, and availability. The issue is fixed in version 3.1.0.