CVE-2026-4137: mlflow/mlflow · Creation of Temporary File With Insecure Permissions
Affects mlflow/mlflowSource CVE Database V5
Mentioned vulnerabilities
Not known to be exploited · CVSS 7.0 High : upgrade to 3.11.0 soon.
Data as of 29 Oct 2026, 19:04 UTC
- EPSS
- 0.1% chance of exploitation in 30 days – higher than 9% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 3.11.0
CVSS:3.0/AV:L/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 18 May 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade mlflow to 3.11.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| mlflowmlflow/mlflow | Affected
| Fixed in– |
PyPImlflowpkg:pypi/mlflowOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
If you cannot patch yet, restrict local access to shared NFS mounts and avoid running untrusted code that deserializes model artifacts. Review and harden permissions on temporary directories used by mlflow to prevent unauthorized modifications.
Description
CVE-2026-4137 is a vulnerability in mlflow/mlflow prior to version 3.11.0 where temporary directories are created with insecure permissions, allowing local attackers to tamper with model artifacts. This can lead to arbitrary code execution when deserialized via cloudpickle.load(). The issue is especially critical in shared NFS environments like Databricks. It continues a previously partially fixed vulnerability class (CVE-2025-10279).