Skip to main content
VulnerabilityPublished Updated

CVE-2026-41387: OpenClaw · Permissive List of Allowed Inputs

Affects OpenClawSource GCVE Database

0

Not known to be exploited · CVSS 8.5 High : upgrade to 2026.3.22 soon.

Data as of 27 Oct 2026, 00:20 UTC

CVSS 4.0 base score
8.5High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 2026.3.22
CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 28 Apr 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade OpenClaw to 2026.3.22.

Affected software

ProductAffectedFixed in
OpenClaw OpenClawAffected
  • <2026.3.22
Fixed in
  • 2026.3.22

AI-suggested

If you cannot patch yet, restrict local user permissions to prevent exploitation and monitor for unusual package resolution behavior.

Description

OpenClaw versions before 2026.3.22 have a vulnerability due to incomplete sanitization of host environment variables in specific configuration files. This flaw allows attackers to override package-manager environment settings, potentially redirecting package resolution or runtime bootstrap processes to attacker-controlled infrastructure, enabling execution of malicious content.

References

Community reviews

Loading reviews…