Skip to main content
VulnerabilityPublished Updated

CVE-2026-41527: KDE Kleopatra · Always-Incorrect Control Flow Implementation

Affects KDE KleopatraSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 6.9 Medium : upgrade to 26.08.0 when convenient.

Data as of 30 Oct 2026, 06:59 UTC

CVSS 3.1 base score
6.9Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.1% chance of exploitation in 30 days – higher than 1% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 26.08.0
CVSS:3.1/AV:L/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:L

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 21 Apr 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade Kleopatra and kde/kleopatra to 26.08.0.

Affected software

ProductAffectedFixed in
KDEKleopatraAffected
  • <26.08.0
Fixed in
  • 26.08.0
GitHubkde/kleopatrapkg:github/kde/kleopatraOther threatsAffected
  • <26.08.0
Fixed in
  • 26.08.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

If you cannot patch yet, restrict local access to trusted users only and monitor for unusual local activity related to Kleopatra instances. Avoid running multiple instances of Kleopatra concurrently as a precaution.

Description

CVE-2026-41527 is a vulnerability in KDE Kleopatra versions before 26.08.0 on Windows. It involves an error in the KUniqueService mechanism that is intended to ensure only one instance of the application runs. Due to this flaw, local users can gain the privileges of a Kleopatra user. The vulnerability has a CVSS score of 6.9, indicating a medium severity level. There are no known exploits in the wild at this time.

References

Community reviews

Loading reviews…