Skip to main content
VulnerabilityPublished Updated

CVE-2026-41582: countly-server · Path Traversal

Affects countly-serverSource CVE Database V5

0

Not known to be exploited · CVSS 7.5 High : upgrade to 25.03.44 or 24.05.50 soon.

Data as of 26 Oct 2026, 14:05 UTC

CVSS 3.1 base score
7.5High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.5% chance of exploitation in 30 days – higher than 44% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 25.03.44, 24.05.50
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 16 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade countly-server and countly/countly-server to 25.03.44 or 24.05.50.

Affected software

ProductAffectedFixed in
Countlycountly-serverAffected
  • >=25.03 <25.03.44
Fixed in
  • 25.03.44
Countlycountly-serverAffected
  • <24.05.50
Fixed in
  • 24.05.50
GitHubcountly/countly-serverpkg:github/countly/countly-serverOther threatsAffected
  • <24.05.50
  • >=25.03 <25.03.44
Fixed in
  • 24.05.50
  • 25.03.44

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade countly-server to version 24.05.50 or later, or 25.03.44 or later, where this path traversal vulnerability is fixed. No other mitigation is required as the fix is official and addresses the issue directly.

Description

CVE-2026-41582 is a path traversal vulnerability in countly-server, the server-side component of the Countly analytics platform. Versions prior to 24.05.50 and 25.03.44 allow unauthenticated attackers to traverse outside intended asset directories via certain public image and screenshot routes. This can lead to disclosure of arbitrary readable server files. The issue is fixed in versions 24.05.50 and 25.03.44.

References

Community reviews

Loading reviews…