Skip to main content
VulnerabilityPublished Updated

CVE-2026-41604: Apache Thrift · Out-of-bounds Read

Affects Apache ThriftSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 8.2 High : upgrade to 0.23.0 soon.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 3.1 base score
8.2High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.9% chance of exploitation in 30 days – higher than 60% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 0.23.0
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 28 Apr 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade Apache Thrift and org.apache.thrift/libthrift to 0.23.0.

Affected software

ProductAffectedFixed in
Apache Software FoundationApache ThriftAffected
  • <0.23.0
Fixed in
  • 0.23.0
Mavenorg.apache.thrift/libthriftpkg:maven/org.apache.thrift/libthriftOther threatsAffected
  • <0.23.0
Fixed in
  • 0.23.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available in Apache Thrift version 0.23.0. Users are strongly advised to upgrade to this version to remediate the vulnerability. Red Hat has issued security advisories and errata addressing this issue for affected products. If upgrading immediately is not possible, monitor vendor advisories for any available mitigations or workarounds. No vendor advisory indicates that no action is required or that the issue is already mitigated without patching.

Description

Out-of-bounds Read vulnerability in Apache Thrift. This issue affects Apache Thrift: before 0.23.0. Users are recommended to upgrade to version 0.23.0, which fixes the issue.

References

Community reviews

Loading reviews…