CVE-2026-41641: nocobase · SQL Injection
Affects nocobaseSource GCVE Database
Not known to be exploited · public detection template (Nuclei) · CVSS 7.2 High : upgrade to 2.0.39 soon.
Data as of 27 Oct 2026, 00:07 UTC
- Patch
- Available – fixed in 2.0.39
CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 7 May 2026
Detectable: evidence found.
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade nocobase to 2.0.39.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| nocobase nocobase | Affected
| Fixed in
|
Description
NocoBase is an AI-powered no-code/low-code platform for building business applications and enterprise solutions. Prior to version 2.0.39, the checkSQL() validation function that blocks dangerous SQL keywords (e.g., pg_read_file, LOAD_FILE, dblink) is applied on the collections:create and sqlCollection:execute endpoints but is entirely missing on the sqlCollection:update endpoint. An attacker with collection management permissions can create a SQL collection with benign SQL, then update it with arbitrary SQL that bypasses all validation, and query the collection to execute the injected SQL and exfiltrate data. This issue has been patched in version 2.0.39.
References
- github.com/nocobase/nocobase/security/advisories/GHSA-wrwh-c28m-9jjh (opens in a new tab)
- github.com/nocobase/nocobase/pull/9134 (opens in a new tab)
- github.com/nocobase/nocobase/commit/851aee543efa894142e0f7be03eb55d9cec06a91 (opens in a new tab)
- github.com/nocobase/nocobase/releases/tag/v2.0.39 (opens in a new tab)